Thursday, October 18, 2012

Cisco Packet Tracer 5.3.3 Slackware 14.0 Installation!

You are Cisco Network Academy member and want to install Cisco Packet Tracer on Slackware 14.0. Unfortunately, only Ubuntu (*.DEB) and Fedora (*.RPM) Packet Tracer download options exist officially, but it is possible to install it on different GNU/Linux distributions including Slackware. Follow this guide to achieve this!

If your system based on 64-bit, you firstly need to switch to multilib for installing Cisco Packet Tracer. (For switching to multilib, look at end of the guide.) 


To download Packet Tracer, you need to log in to Academy Connection (you must be a registered Networking Academy student, alumni, instructor, or administrator).

1. After logging into Academy Connection, select the Packet Tracer graphic to download. Then you will be redirected to the downloads page.




2.  Click on Cisco Packet Tracer Program Downloads link under Software Downloads sub-section.


3. Installing Packet Tracer 5.3.3 from Generic Fedora *.TAR.GZ file, simply by executing install script in it, destroys Slackware 14.0 /etc/profile file. If you do not have a backup of this file, you will need to edit /etc/profile file manually to fix command prompt settings. To avoid this result, we will use *.BIN file instead of *.TAR.GZ file. Now, download "PacketTracer533_i386_installer-rpm.bin" binary file adapted for GNU/Linux Fedora including tutorials.




4.  Open a terminal emulator and change current directory to where downloaded "PacketTracer533_i386_installer-rpm.bin" file locates.


5.  Now, we will extract native Fedora RPM package in BIN file by initializing setup.


Become root,


su


Change file permissions,

chmod 755 PacketTracer533_i386_installer-rpm.bin


Run binary file,

./PacketTracer533_i386_installer-rpm.bin

After running binary file, content of the "PacketTracer533_i386_installer-rpm.bin" file will be extracted to /tmp folder.


6.  Now, for viewing EULA (End User License Agreement), you will be asked to press the ENTER key.





7.  Do not press the ENTER key, just abort the installation by CTRL+C key combination.




8.  Go to /tmp/selfextract.XXXXXX folder ("XXXXXX" is the value assigned by your computer.)


If there is no another /tmp/selfextract.XXXXXX folder in /tmp folder, below command will take the command prompt to the directory where the extracted Fedora RPM package locates.


cd /tmp/selfextract.*


9.  Using RPM2TGZ tool, convert RPM package to TGZ package.


rpm2tgz PacketTracer-5.3_3-u.i386.rpm


10.  Install TGZ package generated by RPM2TGZ tool by using INSTALLPKG tool.


installpkg PacketTracer-5.3_3-u.i386.tgz


11.  Now, we need to add executable symbolic link of Cisco Packet Tracer to /usr/bin directory to be able to start program from command line interface shortly by packettracer command.


ln -s /usr/local/PacketTracer5/packettracer
 /usr/bin/packettracer

12.  Return to user command prompt by exit command.


exit


13.  Start Cisco Packet Tracer as user by packettracer command.


packettracer




IMPORTANT NOTE: If your system based on 64-bit, you firstly need to switch to multilib for installing Cisco Packet Tracer!


To switch multilib with 32-bit compatibility on Slackware64 14.0 using Eric Hameleers' packages and guide;


1. open a terminal emulator,

2. download the complete Slackware 14.0 multilib folder.


lftp -c 'open http://slackware.com/~alien/multilib/ ; mirror 14.0'


3. become root,

su


4. change directory to the downloaded multilib packages' folder. 


cd 14.0


5. upgrade your 64bit Slackware gcc and glibc packages to their multilib versions, 


upgradepkg --reinstall --install-new *.t?z


6. install 32-bit compatibility packages to support all the 32-bit programs, 


cd *-compat32

upgradepkg --install-new *-compat32/*.t?z


7. add below lines to /etc/slackpkg/blacklist file for blacklisting all off multilib and 32-bit compatibility packages against updated by slackpkg tool,

#
# This one will blacklist all alien packages: 
[0-9]+alien
#

For further information about multilib, look at here!

2 comments:

  1. There is also another executable for launching PT at "/usr/local/PacketTracer5/bin/PacketTracer5", but I experienced some problems with that. So, I strongly recommend to use the executable at "/usr/local/PacketTracer5/packettracer" for launching PT as in above guide.

    ReplyDelete
  2. You can download the 5.3.3 and also 6.0.1 version download link in my blog.
    http://myitzn.blogspot.com/

    ReplyDelete